Platform temporarily unavailable - Login issues

Incident Report for Make IT Safe

Resolved

The platform is fully operational. You can now log in as usual.
Thank you for your patience.
Posted May 21, 2026 - 13:00 CEST

Identified

We're currently experiencing a disruption affecting access to the platform. Our team has identified the root cause and a fix is being deployed.

Service is expected to be fully restored within the next few hours.

Thank you for your patience.
Posted May 21, 2026 - 12:00 CEST
This incident affected: Make IT Safe (Grouped SAAS, Dedicated SAAS).