Service unavailable

Incident Report for Make IT Safe

Resolved

The service is now available.

Thank you for your patience.
Posted Apr 02, 2025 - 17:07 CEST

Identified

Some of our shared and dedicated servers are currently inaccessible due to a DNS routing issue with our cloud provider. Maintenance is in progress to resolve the problem. We will keep you updated on the progress. Thank you for your patience.
Posted Apr 02, 2025 - 16:31 CEST
This incident affected: Make IT Safe (Grouped SAAS, Dedicated SAAS).